1
1
openmpi/opal/mca/hwloc
Jeff Squyres 50e5b0937c Add hwloc 1.3.1, but it is not yet the default -- it is currently
.ompi_ignored to allow other developers to test with it.  It is
expected that we'll remove the .ompi_ignore here soon, and
simultaneously remove the hwloc 1.2.2ompi component.

There was one very minor patch added to stock hwloc 1.3.1 in
hwloc/config/hwloc.m4:

{{{
--- hwloc-1.3.1/config/hwloc.m4	2011-12-14 
+++ ompi3/opal/mca/hwloc/hwloc131/hwloc/config/hwloc.m4
@@ -583,6 +583,7 @@
         ])
     fi
     AC_SUBST(HWLOC_PCI_LIBS)
+    HWLOC_LIBS="$HWLOC_LIBS $HWLOC_PCI_LIBS"
     # If we asked for pci support but couldn't deliver, fail
     AS_IF([test "$enable_pci" = "yes" -a "$hwloc_pci_happy" = "no"],
           [AC_MSG_WARN([Specified --enable-pci switch, but could
	   not])
}}}

This will be pushed upstream to hwloc.

This commit was SVN r25706.
2012-01-10 23:38:14 +00:00
..
base Silence a few icc warnings and about mixing enums with other types. 2011-12-02 13:18:54 +00:00
external Fix some problems with the libevent and hwloc frameworks: 2011-09-21 23:06:13 +00:00
hwloc122ompi This commit fixes trac:2917. By using the cleaned up version of check_visibility that is in the hwloc trunk repo. 2011-11-22 00:01:09 +00:00
hwloc131 Add hwloc 1.3.1, but it is not yet the default -- it is currently 2012-01-10 23:38:14 +00:00
configure.m4 We always have hwloc xml support (now that it's built into to hwloc 2011-10-11 20:20:59 +00:00
hwloc.h At long last, the fabled revision to the affinity system has arrived. A more detailed explanation of how this all works will be presented here: 2011-11-15 03:40:11 +00:00
Makefile.am Per the RFC from Jeff, move hwloc from opal/mca/common to its own static framework ala libevent. Have ORTE daemons collect the topology info at startup and, if --enable-hwloc-xml is set, send that info back to the HNP for later use. The HNP only retains unique topology "templates" to reduce memory footprint. Have the daemon include the local topology info in the nidmap buffer sent to each app so the apps don't all hammer the local system to discover it for themselves. 2011-09-11 19:02:24 +00:00
README.txt Add some notes about maintaining the hwloc framework. 2011-09-12 19:40:18 +00:00

12 Sep 2011

Notes for hwloc component maintainers:

1. There can only be *1* hwloc version component at a time.
   Specifically: if there are multiple hwlocXYZ components (i.e.,
   different versions of hwloc), then they must all be .ompi_ignore'd
   except for 1.  This is because we currently m4_include all of the
   underlying hwloc's .m4 files -- if there are multiple hwlocXYZ
   components, I don't know if m4 will barf at the multiple,
   conflicting AC_DEFUNs, or whether it'll just do something
   completely undefined.

1a. As a consequence, if you're adding a new hwloc version component,
   you'll need to .ompi_ignore all others while you're testing the new
   one. 

2. If someone wants to fix #1 someday, we might be able to do what we
   do for libevent: OMPI_CONFIG_SUBDIR (instead of slurping in hwloc's
   .m4 files).