1
1
openmpi/opal/mca/btl/portals4/Makefile.am
Joshua Hursey e1d079544b mca: Dynamic components link against project lib
* Resolves #3705
 * Components should link against the project level library to better
   support `dlopen` with `RTLD_LOCAL`.
 * Extend the `mca_FRAMEWORK_COMPONENT_la_LIBADD` in the `Makefile.am`
   with the appropriate project level library:
```
MCA components in ompi/
       $(top_builddir)/ompi/lib@OMPI_LIBMPI_NAME@.la
MCA components in orte/
       $(top_builddir)/orte/lib@ORTE_LIB_PREFIX@open-rte.la
MCA components in opal/
       $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la
MCA components in oshmem/
       $(top_builddir)/oshmem/liboshmem.la"
```

Note: The changes in this commit were automated by the script in
the commit that proceeds it with the `libadd_mca_comp_update.py`
script. Some components were not included in this change because
they are statically built only.

Signed-off-by: Joshua Hursey <jhursey@us.ibm.com>
2017-08-24 11:56:16 -04:00

59 строки
2.0 KiB
Makefile

#
# Copyright (c) 2004-2006 The Trustees of Indiana University and Indiana
# University Research and Technology
# Corporation. All rights reserved.
# Copyright (c) 2004-2005 The University of Tennessee and The University
# of Tennessee Research Foundation. All rights
# reserved.
# Copyright (c) 2004-2005 High Performance Computing Center Stuttgart,
# University of Stuttgart. All rights reserved.
# Copyright (c) 2004-2005 The Regents of the University of California.
# All rights reserved.
# Copyright (c) 2010 Cisco Systems, Inc. All rights reserved.
# Copyright (c) 2010-2012 Sandia National Laboratories. All rights reserved.
# Copyright (c) 2014 Bull SAS. All rights reserved.
# Copyright (c) 2017 IBM Corporation. All rights reserved.
# $COPYRIGHT$
#
# Additional copyrights may follow
#
# $HEADER$
#
# Make the output library in this directory, and name it either
# mca_<type>_<name>.la (for DSO builds) or libmca_<type>_<name>.la
# (for static builds).
AM_CPPFLAGS = $(btl_portals4_CPPFLAGS)
if MCA_BUILD_opal_btl_portals4_DSO
component_noinst =
component_install = mca_btl_portals4.la
else
component_noinst = libmca_btl_portals4.la
component_install =
endif
local_sources = \
btl_portals4.c \
btl_portals4.h \
btl_portals4_component.c \
btl_portals4_frag.c \
btl_portals4_frag.h \
btl_portals4_rdma.c \
btl_portals4_recv.c \
btl_portals4_recv.h \
btl_portals4_send.c
mcacomponentdir = $(opallibdir)
mcacomponent_LTLIBRARIES = $(component_install)
mca_btl_portals4_la_SOURCES = $(local_sources)
mca_btl_portals4_la_LIBADD = $(top_builddir)/opal/lib@OPAL_LIB_PREFIX@open-pal.la \
$(btl_portals4_LIBS)
mca_btl_portals4_la_LDFLAGS = -module -avoid-version $(btl_portals4_LDFLAGS)
noinst_LTLIBRARIES = $(component_noinst)
libmca_btl_portals4_la_SOURCES = $(local_sources)
libmca_btl_portals4_la_LIBADD = $(btl_portals4_LIBS)
libmca_btl_portals4_la_LDFLAGS = -module -avoid-version $(btl_portals4_LDFLAGS)