From cfcf3fa42df4571273e754cf80fd63e8bf73c0b3 Mon Sep 17 00:00:00 2001
From: Jeff Squyres <jsquyres@cisco.com>
Date: Thu, 2 Oct 2014 03:09:13 -0700
Subject: [PATCH] distscript: whitespace cleanup, remove ancient kruft

There was some (almost) wholly-commented out code in here that reaches
back to the beginning of the project.  Just delete it.
---
 config/distscript.csh | 80 +++++--------------------------------------
 1 file changed, 9 insertions(+), 71 deletions(-)

diff --git a/config/distscript.csh b/config/distscript.csh
index 4ab1382d24..66856b1e0f 100755
--- a/config/distscript.csh
+++ b/config/distscript.csh
@@ -6,15 +6,15 @@
 # Copyright (c) 2004-2005 The University of Tennessee and The University
 #                         of Tennessee Research Foundation.  All rights
 #                         reserved.
-# Copyright (c) 2004-2005 High Performance Computing Center Stuttgart, 
+# Copyright (c) 2004-2005 High Performance Computing Center Stuttgart,
 #                         University of Stuttgart.  All rights reserved.
 # Copyright (c) 2004-2005 The Regents of the University of California.
 #                         All rights reserved.
 # Copyright (c) 2009      Cisco Systems, Inc.  All rights reserved.
 # $COPYRIGHT$
-# 
+#
 # Additional copyrights may follow
-# 
+#
 # $HEADER$
 #
 
@@ -43,12 +43,12 @@ endif
 
 set start=`date`
 cat <<EOF
- 
+
 Creating Open MPI distribution
 In directory: `pwd`
 Version: $OMPI_VERSION
 Started: $start
- 
+
 EOF
 
 umask 022
@@ -180,68 +180,6 @@ foreach file (config.guess config.sub)
 end
 
 
-#
-# Put in date/version number in man pages
-# JMS don't have man pages yet -- this is a straight copy from LAM7
-#
-
-set ver="$OMPI_VERSION"
-#echo "*** Updating version date/number in man pages"
-#rm -f manfiles
-#find man -type f | grep -v Makefile > manfiles
-
-#set date="`date '+%B, %Y'`"
-#cp $srcdir/config/doctext.nroff.def .
-#foreach file (`cat manfiles` doctext.nroff.def)
-#    sed -e "s/-RELEASEDATE-/$date/g" $file > foo
-#    sed -e "s/-RELEASEVERSION-/$ver/g" foo > bar
-#    rm -f $file # Needed 'cause automake makes hard links, not copies
-#    mv bar $file
-#    rm -f foo
-#end
-#rm -f manfiles
-
-#
-# Make all the man pages -- doctext needs to be in your path
-# JMS: Don't have man pages yet; need to do this at some point
-#
-
-#
-# Now we need to list all these generated man pages in the Makefile.am
-# and Makefile.in in man/man3.  Ick!
-# JMS: Will probably need to do this as well.  Sigh.
-#
-
-#echo "*** Frobbing Makefile.am and Makefile.in..."
-#cd ../../man/man3
-#set files="`ls MPI_*3 MPIO_*3 XMPI_*3 MPIL_*3`"
-
-#
-# This is unfortunately necessary because $files is too long to do a
-# single sed search/replace.  Ugh.
-# JMS: Will probably need to do this as well.  Sigh.
-#
-
-#echo "*** Adding man files to Makefile.in..."
-#foreach file ($files)
-#    set name_prefix="`echo $file | cut -c1-4`"
-#    if ("$name_prefix" == "MPI_") then
-#	set letter="`echo $file | cut -c5`"
-#	set div="`expr $letter \> F`"
-#	set line="generated_man_$div"
-#    else
-#	set line="generated_man_other"
-#    endif
-#    echo " - $file / $line"
-#    foreach fix (Makefile.am Makefile.in)
-#	sed -e "s/$line =/$line =$file /" $fix > $fix.new
-#	chmod +w $fix
-#	mv -f $fix.new $fix
-#	chmod -w $fix
-#    end
-#end
-#cd ../..
-
 #
 # Put the release version number in the README and INSTALL files
 #
@@ -251,7 +189,7 @@ echo "*** Updating version number in $files..."
 foreach file ($files)
     echo " - Setting $file"
     if (-f $file) then
-	sed -e "s/OMPI_VERSION/$ver/g" $file > bar
+	sed -e "s/OMPI_VERSION/$OMPI_VERSION/g" $file > bar
 	mv -f bar $file
     endif
 end
@@ -261,10 +199,10 @@ end
 #
 
 cat <<EOF
-*** Open MPI version $ver distribution created
- 
+*** Open MPI version $OMPI_VERSION distribution created
+
 Started: $start
 Ended:   `date`
- 
+
 EOF