diff --git a/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4 b/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
index 3e4e5a5a19..2ec8518924 100644
--- a/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
+++ b/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
@@ -248,6 +248,14 @@ AC_DEFUN([ACVT_COMPWRAP],
esac
])
+ AS_IF([test x"$use_extern_otf" = "xno"],
+ [
+ VT_WRAPPER_CC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
+ VT_WRAPPER_CXX_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CXX_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
+ VT_WRAPPER_FC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_FC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
+ VT_WRAPPER_NVCC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_NVCC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
+ ])
+
AS_IF([test "$PLATFORM" = "macos"],
[
VT_WRAPPER_CC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CC_EXTRA_LINKER_FLAGS -Wl,-force_flat_namespace"
diff --git a/ompi/contrib/vt/vt/configure.ac b/ompi/contrib/vt/vt/configure.ac
index 11fd81b8c5..de3ae34349 100644
--- a/ompi/contrib/vt/vt/configure.ac
+++ b/ompi/contrib/vt/vt/configure.ac
@@ -437,9 +437,6 @@ AM_CONDITIONAL(AMHAVEGPU, test x"$have_cupti_callbacks" = "xyes" -o x"$have_cuda
# Check path for node-local temporary directory
ACVT_LTMPDIR
-# Setup compiler wrappers
-ACVT_COMPWRAP
-
# Check for OTF
ACVT_CONF_TITLE([Open Trace Format (OTF)])
ACVT_OTF
@@ -464,6 +461,9 @@ AS_IF([test x"$enable_config_titles" = "xyes" -a x"$check_vtrun" = "xno"],
[AC_MSG_NOTICE([disabled via command line switch])])
AM_CONDITIONAL(AMBUILDVTRUN, test x"$build_vtrun" = "xyes")
+# Setup compiler wrappers
+ACVT_COMPWRAP
+
# Output files
AC_CONFIG_FILES([Makefile
extlib/Makefile
diff --git a/ompi/contrib/vt/vt/extlib/otf/ChangeLog b/ompi/contrib/vt/vt/extlib/otf/ChangeLog
index 5a25697a02..d37c1b5f23 100644
--- a/ompi/contrib/vt/vt/extlib/otf/ChangeLog
+++ b/ompi/contrib/vt/vt/extlib/otf/ChangeLog
@@ -1,4 +1,8 @@
1.12.2openmpi
+ - fixed conflicts with OpenType Fonts:
+ - install header files to INCLUDEDIR/otf1
+ - install libraries to LIBDIR/otf1
+ - renamed otfdump to otfprint
- OTF library:
- replaced temporary workaround for handling bogus zlib
sync. points by a more elaborated solution
diff --git a/ompi/contrib/vt/vt/extlib/otf/configure.ac b/ompi/contrib/vt/vt/extlib/otf/configure.ac
index 3a3c397739..9af166372e 100644
--- a/ompi/contrib/vt/vt/extlib/otf/configure.ac
+++ b/ompi/contrib/vt/vt/extlib/otf/configure.ac
@@ -25,6 +25,16 @@ AC_ARG_WITH(openmpi-inside, [],
])
])
+# Correct install paths
+AS_IF([test "$inside_openmpi" = "yes" -o "$includedir" = "\${prefix}/include"],
+[includedir="$includedir/otf1"])
+AS_IF([test "$inside_openmpi" = "yes" -o "$libdir" = "\${exec_prefix}/lib" -o "$libdir" = "\${prefix}/lib"],
+[libdir="$libdir/otf1"])
+AS_IF([test "$inside_openmpi" = "yes" -o "$datarootdir" = "\${prefix}/share"],
+[datarootdir="$datarootdir/otf1"])
+AS_IF([test "$docdir" = "\${datarootdir}/doc/\${PACKAGE_TARNAME}"],
+[docdir="\${datarootdir}/doc"])
+
# Get library version
OTF_VERSION_LIBRARY=m4_normalize(esyscmd([config/otf_get_version.sh VERSION --library]))
AC_SUBST([OTF_VERSION_LIBRARY])
diff --git a/ompi/contrib/vt/vt/extlib/otf/docu/tools/otftools.pdf b/ompi/contrib/vt/vt/extlib/otf/docu/tools/otftools.pdf
index 8401077d63..21963df024 100644
Binary files a/ompi/contrib/vt/vt/extlib/otf/docu/tools/otftools.pdf and b/ompi/contrib/vt/vt/extlib/otf/docu/tools/otftools.pdf differ
diff --git a/ompi/contrib/vt/vt/extlib/otf/otflib_py/Makefile.am b/ompi/contrib/vt/vt/extlib/otf/otflib_py/Makefile.am
index a8abe3d23b..67731499fa 100644
--- a/ompi/contrib/vt/vt/extlib/otf/otflib_py/Makefile.am
+++ b/ompi/contrib/vt/vt/extlib/otf/otflib_py/Makefile.am
@@ -14,7 +14,7 @@ pkgpython_PYTHON = __init__.py
nodist_pkgpython_PYTHON = otf.py
pkgpyexec_LTLIBRARIES = _otf.la
nodist__otf_la_SOURCES = otf_wrap.c
-_otf_la_CPPFLAGS = $(SWIG_PYTHON_CFLAGS)
+_otf_la_CPPFLAGS = $(AM_CPPFLAGS) $(SWIG_PYTHON_CFLAGS)
_otf_la_LDFLAGS = -module
_otf_la_LIBADD = $(top_builddir)/otflib/libotf.la
_otf_la_DEPENDENCIES = $(_otf_la_LDADD)
diff --git a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/Makefile.am b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/Makefile.am
index 67ce884e68..bf72b9f552 100644
--- a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/Makefile.am
+++ b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/Makefile.am
@@ -1,13 +1,13 @@
AM_CPPFLAGS = -I$(top_builddir)/otflib -I$(top_srcdir)/otflib
if AMBUILDBINARIES
-bin_PROGRAMS = \
- otfdump
+#bin_PROGRAMS = otfdump # until v1.12.2 (conflicts with otfdump from OpenType Fonts)
+bin_PROGRAMS = otfprint
endif
-otfdump_LDADD = $(top_builddir)/otflib/libotf.la
-otfdump_DEPENDENCIES = $(otfdump_LDADD)
-otfdump_SOURCES = \
+otfprint_LDADD = $(top_builddir)/otflib/libotf.la
+otfprint_DEPENDENCIES = $(otfprint_LDADD)
+otfprint_SOURCES = \
Makefile.am \
Handler.h \
Handler.cpp \
diff --git a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump.cpp b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump.cpp
index dfd89c0088..010ce2527e 100644
--- a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump.cpp
+++ b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump.cpp
@@ -26,10 +26,10 @@ using namespace std;
static const char* Helptext[] = {
" \n",
-" otfdump - Convert an OTF trace or parts of it into a human readable, long \n",
-" version. \n",
+" otfprint - Convert an OTF trace or parts of it into a human readable, long\n",
+" version. \n",
" \n",
-" Syntax: otfdump [options] \n",
+" Syntax: otfprint [options] \n",
" \n",
" options: \n",
" -h, --help show this help message \n",
@@ -62,7 +62,7 @@ static const char* Helptext[] = {
" record-type-numbers can be found in OTF_Definitions.h \n",
" (OTF_*_RECORD) \n",
" \n",
-" -s, --silent do not display anything except the time otfdump \n",
+" -s, --silent do not display anything except the time otfprint \n",
" needed to read the tracefile \n",
" \n",
NULL };
diff --git a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump_vs08.vcproj b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump_vs08.vcproj
index d75eb86119..585ebd3f0f 100644
--- a/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump_vs08.vcproj
+++ b/ompi/contrib/vt/vt/extlib/otf/tools/otfdump/otfdump_vs08.vcproj
@@ -2,9 +2,9 @@