From 79f517941cf133761488186e29f9b29217102e05 Mon Sep 17 00:00:00 2001
From: Jeff Squyres <jsquyres@cisco.com>
Date: Thu, 7 Aug 2014 21:19:46 +0000
Subject: [PATCH] configry: restore "autogen.pl --no-ompi" functionality

Don't use "ompi" names with top-level constructs, because the OMPI
project may not be built.  Instead, just use "opal" names -- they'll
always be there.

This commit was SVN r32446.
---
 configure.ac        | 2 +-
 contrib/Makefile.am | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/configure.ac b/configure.ac
index d5eeea28fe..35b169da8d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1332,7 +1332,7 @@ m4_ifdef([project_ompi], [AC_SUBST(FFLAGS)
 #
 # Aggregate MCA parameters directory
 #
-AC_SUBST([AMCA_PARAM_SETS_DIR], ['$(ompidatadir)/amca-param-sets'])
+AC_SUBST([AMCA_PARAM_SETS_DIR], ['$(opaldatadir)/amca-param-sets'])
 
 ############################################################################
 # final wrapper compiler config
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index baacbbfbab..8a984ac2ed 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -99,4 +99,4 @@ EXTRA_DIST = \
 	platform/mellanox/optimized \
 	platform/mellanox/optimized.conf
 
-dist_ompidata_DATA = openmpi-valgrind.supp
+dist_opaldata_DATA = openmpi-valgrind.supp