diff --git a/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4 b/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
index 2ec8518924..3e4e5a5a19 100644
--- a/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
+++ b/ompi/contrib/vt/vt/config/m4/acinclude.compwrap.m4
@@ -248,14 +248,6 @@ AC_DEFUN([ACVT_COMPWRAP],
esac
])
- AS_IF([test x"$use_extern_otf" = "xno"],
- [
- VT_WRAPPER_CC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
- VT_WRAPPER_CXX_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CXX_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
- VT_WRAPPER_FC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_FC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
- VT_WRAPPER_NVCC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_NVCC_EXTRA_LINKER_FLAGS -L${libdir}/otf1"
- ])
-
AS_IF([test "$PLATFORM" = "macos"],
[
VT_WRAPPER_CC_EXTRA_LINKER_FLAGS="$VT_WRAPPER_CC_EXTRA_LINKER_FLAGS -Wl,-force_flat_namespace"
diff --git a/ompi/contrib/vt/vt/config/m4/acinclude.otf.m4 b/ompi/contrib/vt/vt/config/m4/acinclude.otf.m4
index cb5efc7b8e..f67a4af93a 100644
--- a/ompi/contrib/vt/vt/config/m4/acinclude.otf.m4
+++ b/ompi/contrib/vt/vt/config/m4/acinclude.otf.m4
@@ -32,7 +32,7 @@ AC_DEFUN([ACVT_OTF],
[AS_IF([test x"$OTFDIR" != x], [OTFLIBDIR="-L$OTFDIR"lib/])])
AC_ARG_WITH(otf-lib,
- AC_HELP_STRING([--with-otf-lib=OTFLIB], [use given otf lib, default: -lotf ZLIBLIBDIR ZLIBLIB ZOIDFSLIBDIR ZOIDFSLIB BMILIBDIR BMILIB]),
+ AC_HELP_STRING([--with-otf-lib=OTFLIB], [use given otf lib, default: -lopen-trace-format ZLIBLIBDIR ZLIBLIB ZOIDFSLIBDIR ZOIDFSLIB BMILIBDIR BMILIB]),
[OTFLIB="$withval"])
AC_ARG_WITH(otf-flags,
@@ -52,16 +52,16 @@ AC_DEFUN([ACVT_OTF],
AS_IF([test x"$OTFLIB" = x -a "$otf_error" = "no"],
[
sav_LIBS=$LIBS
- LIBS="$LIBS $OTFLIBDIR -lotf $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"
- AC_MSG_CHECKING([whether linking with -lotf $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB works])
+ LIBS="$LIBS $OTFLIBDIR -lopen-trace-format $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"
+ AC_MSG_CHECKING([whether linking with -lopen-trace-format $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB works])
AC_TRY_LINK([],[],
- [AC_MSG_RESULT([yes]); OTFLIB="-lotf $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"],[AC_MSG_RESULT([no])])
+ [AC_MSG_RESULT([yes]); OTFLIB="-lopen-trace-format $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"],[AC_MSG_RESULT([no])])
LIBS=$sav_LIBS
])
AS_IF([test x"$OTFLIB" = x -a "$otf_error" = "no"],
[
- AC_MSG_NOTICE([error: no libotf found; check path for OTF package first...])
+ AC_MSG_NOTICE([error: no libopen-trace-format found; check path for OTF package first...])
otf_error="yes"
])
],
@@ -184,7 +184,7 @@ dnl [otf_conf_args="$otf_conf_args --with-mpi-inc-dir=`echo $MPIINCDIR | sed s
OTFINCDIR=
OTFLIBDIR=
- AS_IF([test x"$OTFLIB" = x], [OTFLIB="-lotf $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"])
+ AS_IF([test x"$OTFLIB" = x], [OTFLIB="-lopen-trace-format $ZLIBLIBDIR $ZLIBLIB $ZOIDFSLIBDIR $ZOIDFSLIB $BMILIBDIR $BMILIB"])
])
AC_SUBST(OTFDIR)
diff --git a/ompi/contrib/vt/vt/configure.ac b/ompi/contrib/vt/vt/configure.ac
index de3ae34349..11fd81b8c5 100644
--- a/ompi/contrib/vt/vt/configure.ac
+++ b/ompi/contrib/vt/vt/configure.ac
@@ -437,6 +437,9 @@ AM_CONDITIONAL(AMHAVEGPU, test x"$have_cupti_callbacks" = "xyes" -o x"$have_cuda
# Check path for node-local temporary directory
ACVT_LTMPDIR
+# Setup compiler wrappers
+ACVT_COMPWRAP
+
# Check for OTF
ACVT_CONF_TITLE([Open Trace Format (OTF)])
ACVT_OTF
@@ -461,9 +464,6 @@ AS_IF([test x"$enable_config_titles" = "xyes" -a x"$check_vtrun" = "xno"],
[AC_MSG_NOTICE([disabled via command line switch])])
AM_CONDITIONAL(AMBUILDVTRUN, test x"$build_vtrun" = "xyes")
-# Setup compiler wrappers
-ACVT_COMPWRAP
-
# Output files
AC_CONFIG_FILES([Makefile
extlib/Makefile
diff --git a/ompi/contrib/vt/vt/doc/UserManual.html b/ompi/contrib/vt/vt/doc/UserManual.html
index 9053c52b7f..ddcd51e5f3 100644
--- a/ompi/contrib/vt/vt/doc/UserManual.html
+++ b/ompi/contrib/vt/vt/doc/UserManual.html
@@ -2628,7 +2628,7 @@ The CUDA runtime library 3.1 creates a conflict with zlib.
-I$VT_INSTALL_PATH/include/vampirtrace
-L$VT_INSTALL_PATH/lib
-Xcompiler=-g,-finstrument-functions,-pthread
- -lvt -lotf -lcudart -lz -ldl -lm
+ -lvt -lopen-trace-format -lcudart -lz -ldl -lm
$VT_INSTALL_PATH is the path to the VampirTrace installation
directory. It is not necessary to specify the VampirTrace include and library
@@ -3971,7 +3971,7 @@ pass FLAGS to the OTF distribution configuration
-use given otf lib, default: -lotf -lz
+use given otf lib, default: -lopen-trace-format -lz
If the supplied OTF library was built without zlib support then OTFLIB will -be set to -lotf. +be set to -lopen-trace-format.